[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: SVO: Hydraulic Clutch Retrofit



On Wed, 17 Dec 1997 Cameron_Bush@transalta.com wrote:

Sorry if this comes out twice, but my server locked up...I had to retype
this:/

> I put an ETS aluminum flywheel and Centerforce clutch/pressure plate in my
> 86 SVO last year and had no problems until this past month. Several weeks
> ago it felt like the clutch was slipping. After a couple of drives it went
> back to normal, so I thought the adjustment quadrant/pawl thing had snugged
> things up.

sounds like it

 This week my car bucked in first gear several times. Is this a
> symptom of the adjustment mechanism not working properly? It sounds like a
> lot of folks on the list dislike the SVO's adjustment mechanism.
> 
depends what you mean by buck...if you mean violent jerks where the front
end bounces up and down, thats the engine.  If you mean the car shuddered,
with massive vibrations as you let up the clutch, thats chatter.  Chatter
is usually caused by getting something on the disk, usually oil.  it will
slip at first, but then start chattering like crazy..
But I doubt any of these problems are the linkage.


-----------------------------------------------------------------------
		The Pinto Page:  www.eng.usf.edu/~shidel

**Join the turbo 2.3 mailing list by sending your subscription request to:
	ericksco@mhd1.moorhead.msus.edu

Scott
-71 Pinto, stock 2.3 turbo, 13.67@98, radials
	8.1@85 1/8th mile on slicks
	Big intercooler ON!
	T4 Compressor soon to be on!

-85 Merkur, let the modding begin! 
------------------------------------------------------------------------